You are currently browsing the monthly archive for May 2013.

It’s been ages since I’ve posted any pictures of Emerson, so here are a few from a recent outing. Emerson and I decided to go for a walk at the Battlefield, and Kim had the clever idea of turning it into a scavenger hunt!

IMG_20130518_154518

Here’s the (completed) list of items we had to find.

Most of them we checked off before we even left the parking lot at the Battlefield:

IMG_20130518_143252

Rock

IMG_20130518_143317

Green Leaf

IMG_20130518_143354

Yellow Flower

IMG_20130518_143441

White Flower

IMG_20130518_143508

Twig

IMG_20130518_143540

Water

IMG_20130518_143624

Pine Tree

IMG_20130518_143748

Pine Cone (it’s prickly)

IMG_20130518_143833

Grass

IMG_20130518_143938

Log

IMG_20130518_144352

Sweetgum Ball

Then we actually went on our hike for awhile.

IMG_20130518_145741

IMG_20130518_145812

…before we started finding things again.

IMG_20130518_150344

It’s hard to see, but this is an old hulled-out, half-eaten acorn.

IMG_20130518_150639

Here’s a nymph of some kind, which counts as a bug for us. We saw a moth and ants and lots of mosquitoes, too, but this was the best picture we got.

IMG_20130518_150855

This is kind of cheating. It was an overcast, rainy day, so while we heard birds everywhere, we didn’t see a single one until we were in the car on the way home.  But we did notice this eagle at the very top of the monument. That counts, right?

And here’s a bonus picture of Emerson getting ready for his favorite movie recently:

IMG_20130421_145848

Late last year we started seeing a check engine light on the PT Cruiser. When I checked the code on the OBD-II reader, the only one that came up was P0551 – Power Steering Switch Failure. After doing a little bit of research, I found that this is a relatively minor problem – the only danger from a switch failure is low idle speeds when the power steering is used, and even though it was a relatively inexpensive issue to fix at the shop (the quote was about $140; compare to the several thousands for other codes I’ve encountered in the past), we weren’t rolling in money. Unfortunately, since you can’t pass an emissions test if you show any code at all, and you can’t renew your tags without passing an emission test, it had to get fixed eventually.

After researching the repair (especially here) it seemed like something I could do myself relatively easily. I ended up spending about $55 at NAPA – I bought the replacement switch, a 7/8ths deep-socket as suggested, a container of electronics cleaner, and a bottle of power steering fluid.

IMG_20130518_121056

First things first. Because you’re dealing with electronics, you have to disconnect the battery. Disconnect the negative battery terminal, which is on the right hand side of the battery if you’re standing at the front of the car. The battery is located beneath the air filter cover, which can be removed by unclasping the two clips on either side (see the video link above). A mechanic in the past showed me how to remove the entire air filter assembly in the past, but over time this damages the assembly, and it’s difficult to reseat. Just use the clips instead.

Note that whether you touch anything else or not, because you disconnected the battery the code will clear, and you’ll have to drive at least 5 miles or so before it will return, so don’t get excited if you reconnect the battery at this point and the code is gone. Drive it to the store and back before rejoicing.  If, like me, you’re looking to pass an emissions test after doing this work, you’ll probably need to do some significant driving after you perform this operation (or about 50 engine starts, per the web research I did), or they’ll fail you for a recent battery disconnect.

IMG_20130518_121128

Next step – lift the driver’s side front wheel enough to let you get under the car.  The jack goes right where your body and arms are going to want to be, so – even though with the weight of the car on it the jack isn’t likely to slip – safety first and put a jack-stand underneath as well.

IMG_20130518_121110

At least, I’d rather have these holding the car up than my ribs.

 

IMG_20130518_121348

This is the view beneath the car, looking toward the front.  There are several sensory looking things here, so make sure you get the right one. The think you’re looking for is this:

IMG_20130518_121342 edit

It’s the piece circled in red. The plastic clip on the end slips right off when you unhook the clasp.

IMG_20130518_122024

The plastic clip looks like this when you get it free. As you can see, it’s covered in something – oil possibly, or power steering fluid more likely.  Several people have mentioned that this is enough to cause the code to appear, and have suggested using electronics cleaner like the below is enough to make the code go away.

IMG_20130518_121609

That’s entirely possible, but since I don’t feel like jacking the car up twice, delaying the emissions test by waiting through another 50 starts, and since the part is cheap enough, might as well do both things at once.

IMG_20130518_122203

Mask off the area so you don’t overspray cleaner all over everything (it’s not good for rubber), and spray it now, so it can dry.

IMG_20130518_123007

A single extension on the ratchet with the deep socket was the perfect fit in a cramped space. Once the friction on the threads was broken, the sensor unscrewed easily by hand.

IMG_20130518_122432

The Power steering fluid is going to drain, so make sure you have something to catch it with.

IMG_20130518_122623

Compare new and old parts (the worst time to find out you bought the wrong piece is after you’ve spent 30 minutes trying to install it), and simply undo the above process. You can screw the sensor in most of the way by hand, and use the ratchet to tighten it. The hardest part of this whole process for me was trying to match up the plastic clip with the sensor – the fit is very snug, the alignment has to be exact, and after five minutes of trying to fit it, I was beginning to think I’d gotten the wrong part after all. It doesn’t need to be forced – you just have to line up the plug perfectly into the socket.  Don’t forget to reconnect the battery once you have the car back on the ground, and to clip the air filter cover back into place.

IMG_20130518_123617

Since the power steering fluid drained out, it has to be replaced. After checking the level several times along the way, I ended up adding the whole bottle.  And since no DIY job is complete without at least one trip to the shop along the way, I went back to get a second bottle. The steering was loud and grumbly when I started the car up at first, and whined whenever I pulled on the wheel. After driving it around the block once, I checked the levels again and the fluid had settled considerably, I needed about half of the second bottle to bring the fluid to the hot fill line.

30 miles and 10 starts later, no codes have returned and the steering sounds beautiful.

Categories

May 2013
M T W T F S S
« May    
 12345
6789101112
13141516171819
20212223242526
2728293031